Prepárese para el lanzamiento principal de Joomla! 4 – Actualizate ahora!

Desde la versión 3.7.0 se ha comenzado a trabajar con Joomla! 4.0 por lo que se esta aumentando los requisitos mínimos del servidor.

Los requisitos mínimos son los siguientes:

  • PHP 5.5.9
  • MySQL 5.5.3
  • PostgreSQL 9.2
  • MS SQL no se soportará
  • MySQL usando la extensión de PHP ‘ext/mysql’ en modo legado no se soportará, MySQLi o PDO MySQL deberá usarse en su lugar

Mantengase actualizado y contáctenos.


Última actualización Joomla! 3.8

Sistema de enrutamiento mejorado ¡URLs más limpias, cortas y amigables!

Nuevas opciones para darte más control sobre la estructura de tus URLs, incluyendo la tan esperada característica de “quitar IDs”. Diseñado para ayudarte a mejorar el SEO, puedes beneficiarte de estas mejoras al instante en todos tus nuevos sitios *.

Preparando el terreno para Joomla! 4

Una migración suave a nuestra próxima versión

Joomla! 3.8 incluye una capa de compatibilidad con Joomla! 4. Las clases PHP del núcleo se moverán a namespaces PHP en Joomla! 4. Para hacer el desarrollo de extensiones y la transición suaves, la mayoría de las clases de la biblioteca del núcleo ya tienen namespaces en Joomla! 3.8 con alias de clase para garantizar la compatibilidad hacia atrás.

Joomla! 4

En el último año, se ha dedicado mucho esfuerzo a la construcción de la próxima generación de Joomla para trabajar en Joomla! 4.0 y Joomla! Lanzamientos de Framework 2.0. Además de presentar varias características nuevas, incluyendo un administrador de medios completamente reconstruido, un sistema mejorado de despacho de eventos y nuevas características de seguridad tales como soporte para declaraciones SQL preparadas, también hemos estado haciendo un mantenimiento de rutina y pagando parte de la deuda técnica de nuestro proyecto retirando el código obsoleto y aumentando la pila de software mínima admitida. En una actualización del manifiesto del año pasado, hoy nos gustaría anunciar que las próximas versiones importantes de Joomla requerirán PHP 7.

¿Por qué PHP 7?

Actualmente, PHP 7 es la única versión principal totalmente compatible del lenguaje PHP, con soporte para el final del PHP 5 (actualmente solo 5.6 recibe actualizaciones de seguridad y ya no se admiten todas las versiones anteriores). Por el momento Joomla! 4, la versión PHP soportada más antigua tendrá menos de un año de soporte de seguridad restante.

Al mirar la vida total de Joomla! 3.x, cuyo primer lanzamiento fue en septiembre de 2012, Joomla! 3.x tendrá un mínimo de ocho años de soporte para cuando llegue a su fin de la fecha de soporte. ¡Suponiendo que Joomla! 4 lanzamientos en 2018 y tiene una vida similar, esto significa Joomla! 4 podría ser soportado mucho más allá de 2025. Como puede ver, este es un gran marco de tiempo para admitir software, especialmente software cuyo objetivo principal es crear y administrar sitios web. Mirando hacia las necesidades futuras de soporte de nuestro proyecto, cómo la industria web en su conjunto está evolucionando (incluidas las tecnologías de las que depende directamente Joomla para funcionar), y utilizando nuestra estrategia de desarrollo existente para guiarnos, los lanzamientos de Joomla! 4.0 y Joomla! Framework 2.0 es nuestra única oportunidad para volver a evaluar nuestras versiones de software compatibles durante bastante tiempo.

Adoptando a PHP 7

PHP 7 fue un lanzamiento importante para el lenguaje PHP, que requería la mayoría de los paquetes de software y extensiones para que el lenguaje mismo realizara actualizaciones en diversos grados. En cuanto a las estadísticas de uso que ofrece nuestra comunidad, de todas las instalaciones que han proporcionado datos desde que se lanzó el sistema a principios de 2016, aproximadamente el 17% de los sitios informan que ejecutan una versión de PHP 7. Este número puede parecer bajo, pero el servidor de estadísticas contiene datos de todos los sitios que alguna vez informaron información y los datos públicos incluyen sitios que ya no están en línea o han optado por no enviar datos por más tiempo. Por lo tanto, también analizamos los datos de uso de los sitios que informan un Joomla! 3.7 y han encontrado que el 42% de esos sitios están ejecutando una versión de PHP 7. Otra tendencia interesante que hemos notado en el transcurso de 2017 es el aumento en el número de sitios que ejecutan un lanzamiento de PHP 7 y la disminución en los sitios que ejecutan PHP 5.5 o anterior. Al usar esta información, nos sentimos cómodos con la tasa de adopción en nuestra comunidad de PHP 7 y que requerir PHP 7 para la próxima generación de Joomla no es una petición irracional.

¿Qué sucede si no puedo actualizar?

Una cosa importante para recordar es Joomla! 3.9, nuestra última versión 3.x programada, será compatible durante dos años después de su lanzamiento. ¡De manera similar para Joomla! Los usuarios de Framework, los paquetes Framework 1.x serán soportados por aproximadamente el mismo período de tiempo (especialmente cuando el CMS tiene dependencias incorporadas a muchos paquetes de Framework). De nuevo, asumiendo Joomla! 4.0 lanzamientos en 2018, esto significa que puede ejecutar su Joomla! 3 sitio cómodamente hasta 2020. Para 2020, será más urgente actualizar, ya que no solo su versión de Joomla ya no será compatible, sino que la mayoría de las versiones de PHP ejecutarán Joomla! 3 no será compatible, al igual que muchos paquetes de software de servidor y distribuciones.

¿Cómo afectará esto el código central?

Con Joomla! La versión PHP mínima de 3 es PHP 5.3.10, existen numerosas características y optimizaciones que podemos hacer en nuestro código a medida que eliminamos el soporte de PHP 5. Muchos de estos cambios se pueden realizar sin afectar la API pública existente, sin embargo, algunas características (por ejemplo, sugerencias de tipo escalar) si se implementan introducirían saltos de compatibilidad con versiones anteriores si se aceptan. Por lo tanto, estaremos adaptando las siguientes políticas en lo que se refiere a Joomla! 4.0, Joomla! Framework 2.0, y código nuevo y existente:

Todas las nuevas clases y métodos en las nuevas versiones principales pueden hacer uso de todas las características disponibles en PHP 7, incluidas las escrituras de tipo escalares y las declaraciones de tipo de retorno.
Los métodos privados y los métodos en las clases finales (que no pueden ampliarse por definición) se pueden actualizar para usar PHP 7 escribiendo
Los métodos públicos y protegidos en clases existentes generalmente no cambiarán sus firmas de método a menos que el cambio mejore la comprensión y el uso del código (por ejemplo, métodos que podrían usar firmas variadic)

Fuente: https://developer.joomla.org/

 

, ,
Derechos Reservados © 1998-2017 Y2K Webs :: Soluciones Profesionales para Internet :: Costa Rica - España - Argentina.
Scroll to Top